Game Streaming
Incident Report for WJON IP Radio
Resolved
Back to normal programming
Posted Feb 13, 2022 - 22:37 EST
Investigating
Our stream of the game is unstable due to load on the provider. We apologize for the inconsistencies and the inconvenience.
Posted Feb 13, 2022 - 20:09 EST
This incident affected: Main (Music).